// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<[a-z]+ .*?(href|src|alt)="[^"]+""#).unwrap();
let string = "<p>paragraph<a>link</a></p>
<div class=\"myclass\">
<div>something</div>
<div style=\"mystyle\">something</div>
<b><a href=\"#\">link</a></b>
<b><a href=\"#\" name=\"a name\">link</a></b>
<b style=\"color:red\">bold</b>
<img src=\"../path\" alt=\"something\" />
<img src=\"../path\" alt=\"something\" class=\"myclass\" />
</div>'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}