using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:var|const)\s*([a-z$_]+\s*=\s*require\(('|"")(?:assert|fs|path|child_process)\2\),?[\n\r\t\s]*)*;$";
string input = @"var pth = require(""path"");
const asrt = require('assert'),
fs = require('fs'),
cp = require('child_process');
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}