re = /^(?:var|const)\s*([a-z$_]+\s*=\s*require\(('|")(?:assert|fs|path|child_process)\2\),?[\n\r\t\s]*)*;$/m
str = 'var pth = require("path");
const asrt = require(\'assert\'),
fs = require(\'fs\'),
cp = require(\'child_process\');
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end