import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:var|const)\\s*([a-z$_]+\\s*=\\s*require\\(('|\")(?:assert|fs|path|child_process)\\2\\),?[\\n\\r\\t\\s]*)*;$";
final String string = "var pth = require(\"path\");\n"
+ "const asrt = require('assert'),\n"
+ " fs = require('fs'),\n"
+ " cp = require('child_process');\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}