$re = '/^(?:var|const)\s*([a-z$_]+\s*=\s*require\((\'|")(?:assert|fs|path|child_process)\2\),?[\n\r\t\s]*)*;$/m';
$str = 'var pth = require("path");
const asrt = require(\'assert\'),
fs = require(\'fs\'),
cp = require(\'child_process\');
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);