import re
regex = re.compile(r"^(?:var|const)\s*([a-z$_]+\s*=\s*require\(('|\")(?:assert|fs|path|child_process)\2\),?[\n\r\t\s]*)*;$", flags=re.MULTILINE)
test_str = ("var pth = require(\"path\");\n"
"const asrt = require('assert'),\n"
" fs = require('fs'),\n"
" cp = require('child_process');\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")