const regex = /^(?:var|const)\s*([a-z$_]+\s*=\s*require\(('|")(?:assert|fs|path|child_process)\2\),?[\n\r\t\s]*)*;$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:var|const)\\s*([a-z$_]+\\s*=\\s*require\\((\'|")(?:assert|fs|path|child_process)\\2\\),?[\\n\\r\\t\\s]*)*;$', 'gm')
const str = `var pth = require("path");
const asrt = require('assert'),
fs = require('fs'),
cp = require('child_process');
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}