#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)(?<=\d{2} )\+(?=\d{4})"
Local $sString = "[12/Oct/2015:00:37:29 +0200]" & @CRLF & _
"[12/Oct/2015:00:37:x9 +0200]" & @CRLF & _
"[12/Oct/2015:00:37:29 +020x]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")