import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d{2} )\\+(?=\\d{4})";
final String string = "[12/Oct/2015:00:37:29 +0200]\n"
+ "[12/Oct/2015:00:37:x9 +0200]\n"
+ "[12/Oct/2015:00:37:29 +020x]";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}