$re = '/(?<=\d{2} )\+(?=\d{4})/si';
$str = '[12/Oct/2015:00:37:29 +0200]
[12/Oct/2015:00:37:x9 +0200]
[12/Oct/2015:00:37:29 +020x]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);