using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)([0-9]{6}.[0-9]{6}.log)";
string input = @"\servername\logs\e2serverd.20210107.000000.691088.log
\servername\logs\e2serverd.20210107.111111.123423.log";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}