package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)([0-9]{6}.[0-9]{6}.log)`)
var str = `\servername\logs\e2serverd.20210107.000000.691088.log
\servername\logs\e2serverd.20210107.111111.123423.log`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}