// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)([0-9]{6}.[0-9]{6}.log)").unwrap();
let string = "\\servername\\logs\\e2serverd.20210107.000000.691088.log
\\servername\\logs\\e2serverd.20210107.111111.123423.log";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}