$re = '/(.*)([0-9]{6}.[0-9]{6}.log)/m';
$str = '\\servername\\logs\\e2serverd.20210107.000000.691088.log
\\servername\\logs\\e2serverd.20210107.111111.123423.log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);