import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)([0-9]{6}.[0-9]{6}.log)";
final String string = "\\servername\\logs\\e2serverd.20210107.000000.691088.log\n"
+ "\\servername\\logs\\e2serverd.20210107.111111.123423.log";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}