#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "if (matches_regular_expression(url, '.*[.]([A-Za-z0-9-]+.com)')) then ( url = $1;)" & @CRLF & _
""
Local $sString = "Receiving datame2->$@<CTR>&CTData=<G><TT>d</TT>00<X>Approved</CTR>" & @CRLF & _
"Receiving datame2->$@<CTR>&CTData=<G><R>^@^<T>0Y<X>Approved</CTR>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")