import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "if (matches_regular_expression(url, '.*[.]([A-Za-z0-9-]+.com)')) then ( url = $1;)\n";
final String string = "Receiving datame2->$@<CTR>&CTData=<G><TT>d</TT>00<X>Approved</CTR>\n"
+ "Receiving datame2->$@<CTR>&CTData=<G><R>^@^<T>0Y<X>Approved</CTR>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}