package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`if (matches_regular_expression(url, '.*[.]([A-Za-z0-9-]+.com)')) then ( url = $1;)
`)
var str = `Receiving datame2->$@<CTR>&CTData=<G><TT>d</TT>00<X>Approved</CTR>
Receiving datame2->$@<CTR>&CTData=<G><R>^@^<T>0Y<X>Approved</CTR>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}