re = /if (matches_regular_expression(url, '.*[.]([A-Za-z0-9-]+.com)')) then ( url = $1;)
/
str = 'Receiving datame2->$@<CTR>&CTData=<G><TT>d</TT>00<X>Approved</CTR>
Receiving datame2->$@<CTR>&CTData=<G><R>^@^<T>0Y<X>Approved</CTR>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end