// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"if (matches_regular_expression(url, '.*[.]([A-Za-z0-9-]+.com)')) then ( url = $1;)
").unwrap();
let string = "Receiving datame2->$@<CTR>&CTData=<G><TT>d</TT>00<X>Approved</CTR>
Receiving datame2->$@<CTR>&CTData=<G><R>^@^<T>0Y<X>Approved</CTR>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}