const regex = /if (matches_regular_expression(url, '.*[.]([A-Za-z0-9-]+.com)')) then ( url = $1;)
/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('if (matches_regular_expression(url, \'.*[.]([A-Za-z0-9-]+.com)\')) then ( url = $1;)
', 'g')
const str = `Receiving datame2->\$@<CTR>&CTData=<G><TT>d</TT>00<X>Approved</CTR>
Receiving datame2->\$@<CTR>&CTData=<G><R>^@^<T>0Y<X>Approved</CTR>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}