#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^" & @CRLF & _
" (?=.{0,3}\d)(?=.{0,3}[a-zA-Z])[a-zA-Z0-9]{4} # Main part" & @CRLF & _
" (," & @CRLF & _
" (?=.{0,3}\d)(?=.{0,3}[a-zA-Z])[a-zA-Z0-9]{4}" & @CRLF & _
" )*" & @CRLF & _
"$"
Local $sString = "eeewqq2312312412rew" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")