import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ " (?=.{0,3}\\d)(?=.{0,3}[a-zA-Z])[a-zA-Z0-9]{4} # Main part\n"
+ " (,\n"
+ " (?=.{0,3}\\d)(?=.{0,3}[a-zA-Z])[a-zA-Z0-9]{4}\n"
+ " )*\n"
+ "$";
final String string = "eeewqq2312312412rew\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}