$re = '/^
(?=.{0,3}\d)(?=.{0,3}[a-zA-Z])[a-zA-Z0-9]{4} # Main part
(,
(?=.{0,3}\d)(?=.{0,3}[a-zA-Z])[a-zA-Z0-9]{4}
)*
$/';
$str = 'eeewqq2312312412rew
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);