package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^
(?=.{0,3}\d)(?=.{0,3}[a-zA-Z])[a-zA-Z0-9]{4} # Main part
(,
(?=.{0,3}\d)(?=.{0,3}[a-zA-Z])[a-zA-Z0-9]{4}
)*
$`)
var str = `eeewqq2312312412rew
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}