import re
regex = re.compile((r"^\n"
r" (?=.{0,3}\d)(?=.{0,3}[a-zA-Z])[a-zA-Z0-9]{4} # Main part\n"
r" (,\n"
r" (?=.{0,3}\d)(?=.{0,3}[a-zA-Z])[a-zA-Z0-9]{4}\n"
r" )*\n"
r"$"))
test_str = ("eeewqq2312312412rew\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")