re = /^
(?=.{0,3}\d)(?=.{0,3}[a-zA-Z])[a-zA-Z0-9]{4} # Main part
(,
(?=.{0,3}\d)(?=.{0,3}[a-zA-Z])[a-zA-Z0-9]{4}
)*
$/
str = 'eeewqq2312312412rew
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end