using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\+\-]?\d+\.?\d*[\+\-\*\/]?)";
string input = @"1001.111+232323.2221u
-1111.2
1111.222/22222/2
-11111+222.3/4
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}