// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\+\-]?\d+\.?\d*[\+\-\*\/]?)").unwrap();
let string = "1001.111+232323.2221u
-1111.2
1111.222/22222/2
-11111+222.3/4
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}