$re = '/([\+\-]?\d+\.?\d*[\+\-\*\/]?)/';
$str = '1001.111+232323.2221u
-1111.2
1111.222/22222/2
-11111+222.3/4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);