import re
regex = re.compile(r"([\+\-]?\d+\.?\d*[\+\-\*\/]?)")
test_str = ("1001.111+232323.2221u\n"
"-1111.2\n"
"1111.222/22222/2\n"
"-11111+222.3/4\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")