#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=^|\s)(?=[A-Z\d]*[a-z])(?=[a-z\d]*[A-Z])(?=[a-zA-Z]*[\d])[a-zA-Z\d]{6,30}(?=$|\s)"
Local $sString = "am2Nals2kdP5 This is some sample text containing an email address of michael.knight@knightrider2000.com " & @CRLF & _
"and some cryptic secret like am2Nals2kdP5 and even more text. amdNalsfkdPt test am2Nals2kdP5" & @CRLF & _
"" & @CRLF & _
"#$#fDD5555555" & @CRLF & _
"am2Nals2kdP5am2Nals2kdP5" & @CRLF & _
"fffddD2" & @CRLF & _
"" & @CRLF & _
"am2Nals2kdP5am2Nals2kdP5" & @CRLF & _
"am2Nals2kdP5" & @CRLF & _
"am2Nals2kdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")