use strict;
my $str = 'am2Nals2kdP5 This is some sample text containing an email address of michael.knight@knightrider2000.com
and some cryptic secret like am2Nals2kdP5 and even more text. amdNalsfkdPt test am2Nals2kdP5
#$#fDD5555555
am2Nals2kdP5am2Nals2kdP5
fffddD2
am2Nals2kdP5am2Nals2kdP5
am2Nals2kdP5
am2Nals2kdf';
my $regex = qr/(?<=^|\s)(?=[A-Z\d]*[a-z])(?=[a-z\d]*[A-Z])(?=[a-zA-Z]*[\d])[a-zA-Z\d]{6,30}(?=$|\s)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}