const regex = /(?<=^|\s)(?=[A-Z\d]*[a-z])(?=[a-z\d]*[A-Z])(?=[a-zA-Z]*[\d])[a-zA-Z\d]{6,30}(?=$|\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|\\s)(?=[A-Z\\d]*[a-z])(?=[a-z\\d]*[A-Z])(?=[a-zA-Z]*[\\d])[a-zA-Z\\d]{6,30}(?=$|\\s)', 'g')
const str = `am2Nals2kdP5 This is some sample text containing an email address of michael.knight@knightrider2000.com
and some cryptic secret like am2Nals2kdP5 and even more text. amdNalsfkdPt test am2Nals2kdP5
#\$#fDD5555555
am2Nals2kdP5am2Nals2kdP5
fffddD2
am2Nals2kdP5am2Nals2kdP5
am2Nals2kdP5
am2Nals2kdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}