re = /(?<=^|\s)(?=[A-Z\d]*[a-z])(?=[a-z\d]*[A-Z])(?=[a-zA-Z]*[\d])[a-zA-Z\d]{6,30}(?=$|\s)/
str = 'am2Nals2kdP5 This is some sample text containing an email address of michael.knight@knightrider2000.com
and some cryptic secret like am2Nals2kdP5 and even more text. amdNalsfkdPt test am2Nals2kdP5
#$#fDD5555555
am2Nals2kdP5am2Nals2kdP5
fffddD2
am2Nals2kdP5am2Nals2kdP5
am2Nals2kdP5
am2Nals2kdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end