# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=^|\s)(?=[A-Z\d]*[a-z])(?=[a-z\d]*[A-Z])(?=[a-zA-Z]*[\d])[a-zA-Z\d]{6,30}(?=$|\s)"
test_str = ("am2Nals2kdP5 This is some sample text containing an email address of michael.knight@knightrider2000.com \n"
"and some cryptic secret like am2Nals2kdP5 and even more text. amdNalsfkdPt test am2Nals2kdP5\n\n"
"#$#fDD5555555\n"
"am2Nals2kdP5am2Nals2kdP5\n"
"fffddD2\n\n"
"am2Nals2kdP5am2Nals2kdP5\n"
"am2Nals2kdP5\n"
"am2Nals2kdf")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.