import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|\\s)(?=[A-Z\\d]*[a-z])(?=[a-z\\d]*[A-Z])(?=[a-zA-Z]*[\\d])[a-zA-Z\\d]{6,30}(?=$|\\s)";
final String string = "am2Nals2kdP5 This is some sample text containing an email address of michael.knight@knightrider2000.com \n"
+ "and some cryptic secret like am2Nals2kdP5 and even more text. amdNalsfkdPt test am2Nals2kdP5\n\n"
+ "#$#fDD5555555\n"
+ "am2Nals2kdP5am2Nals2kdP5\n"
+ "fffddD2\n\n"
+ "am2Nals2kdP5am2Nals2kdP5\n"
+ "am2Nals2kdP5\n"
+ "am2Nals2kdf";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}