#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\S)(\s){2,}(?=\S)"
Local $sString = " Hi, this is a good time to start working together." & @CRLF & _
"Hi, this is a good time to start working together." & @CRLF & _
"Hi, this is a good time to start working together. "
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)