using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S)(\s){2,}(?=\S)";
string substitution = @"\1\2";
string input = @" Hi, this is a good time to start working together.
Hi, this is a good time to start working together.
Hi, this is a good time to start working together. ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}