const regex = /(\S)(\s){2,}(?=\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S)(\\s){2,}(?=\\S)', 'gm')
const str = ` Hi, this is a good time to start working together.
Hi, this is a good time to start working together.
Hi, this is a good time to start working together. `;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);