import Foundation
let pattern = #"(\S)(\s){2,}(?=\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hi, this is a good time to start working together.
Hi, this is a good time to start working together.
Hi, this is a good time to start working together.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)