use strict;
my $str = ' Hi, this is a good time to start working together.
Hi, this is a good time to start working together.
Hi, this is a good time to start working together. ';
my $regex = qr/(\S)(\s){2,}(?=\S)/mp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";