using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w[\w'’-]*\w|\w)";
string input = @"I O U woo
hello world
isn't it great. Isn’t it ""swell""?
{and 'this'} is some javascript ""testing"" with “quotes” and ‘quotes’. Even ‘bad‘ “quotes“ ”going”the’wrong’ way
'hello''world''stuff's'
some low-dashed words too h-bar";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}