$re = '/(\w[\w\'’-]*\w|\w)/im';
$str = 'I O U woo
hello world
isn\'t it great. Isn’t it "swell"?
{and \'this\'} is some javascript "testing" with “quotes” and ‘quotes’. Even ‘bad‘ “quotes“ ”going”the’wrong’ way
\'hello\'\'world\'\'stuff\'s\'
some low-dashed words too h-bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);