// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(\w[\w'’-]*\w|\w)").unwrap();
let string = "I O U woo
hello world
isn't it great. Isn’t it \"swell\"?
{and 'this'} is some javascript \"testing\" with “quotes” and ‘quotes’. Even ‘bad‘ “quotes“ ”going”the’wrong’ way
'hello''world''stuff's'
some low-dashed words too h-bar";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}