const regex = /(\w[\w'’-]*\w|\w)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w[\\w\'’-]*\\w|\\w)', 'gim')
const str = `I O U woo
hello world
isn't it great. Isn’t it "swell"?
{and 'this'} is some javascript "testing" with “quotes” and ‘quotes’. Even ‘bad‘ “quotes“ ”going”the’wrong’ way
'hello''world''stuff's'
some low-dashed words too h-bar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}