import re
regex = re.compile(r"(\w[\w'’-]*\w|\w)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("I O U woo\n"
"hello world \n"
"isn't it great. Isn’t it \"swell\"?\n"
"{and 'this'} is some javascript \"testing\" with “quotes” and ‘quotes’. Even ‘bad‘ “quotes“ ”going”the’wrong’ way\n"
"'hello''world''stuff's'\n"
"some low-dashed words too h-bar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")