import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w[\\w'’-]*\\w|\\w)";
final String string = "I O U woo\n"
+ "hello world \n"
+ "isn't it great. Isn’t it \"swell\"?\n"
+ "{and 'this'} is some javascript \"testing\" with “quotes” and ‘quotes’. Even ‘bad‘ “quotes“ ”going”the’wrong’ way\n"
+ "'hello''world''stuff's'\n"
+ "some low-dashed words too h-bar";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}