using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z] + [^0-9\s.]+|\.(?!\d)";
string substitution = @"";
string input = @"asdsad $59.33 9. .3 as.df 2 asdf 56 89 .a 2.4 wef 95 as.5df. 67.990 dssdgsfh.gdfgdlkblbllgff.njyn.j.njljn.jn.j.jnjnn.jn.n.n.vvfbvhfbhbfhbvhfbvhf.ghfghrughu.gktigjti";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}