const regex = /[a-z] + [^0-9\s.]+|\.(?!\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-z] + [^0-9\\s.]+|\\.(?!\\d)', 'g')
const str = `asdsad \$59.33 9. .3 as.df 2 asdf 56 89 .a 2.4 wef 95 as.5df. 67.990 dssdgsfh.gdfgdlkblbllgff.njyn.j.njljn.jn.j.jnjnn.jn.n.n.vvfbvhfbhbfhbvhfbvhf.ghfghrughu.gktigjti`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);